Windows Unattended CD Creator

Quell-CD

  • Der Windows-Unattended-CD-Creator präsentiert sich nach Ablauf der Einwandfrei erstellten Installationsroutine, ohne großartigem "Schnickschnack" mit einem übersichtlichen Gesamtüberblick und dem Ersten Anforderungsfenster.

Beginnen Sie mit der Angabe des Quell-Verzeichnisses. Aufgrund des schnelleren Datenzugriffs, empfiehlt es sich, den gesamten Inhalt der Windows-CD in einen Ordner zu kopieren. In diesem Beispiel hatte ich die Windows Installations-CD auf E:\ in den Ordner $OEM$ kopiert.

Es folgt die Angabe des Ziel-Ordners. Dazu wird ein Ordner Namens "$OEM_NEW$" erstellt um das fertige Image dort abzuspeichern. Anschließend drücken Sie auf "Quell-CD auslesen". Dabei wird Inhalt des Ordners E:\$OEM$ ins Verzeichnis $OEM_NEW$ kopiert. Dort werden im weiteren nun alle Veränderungen vorgenommen. Ist dieses Verzeichnis bereits mit Daten gefüllt, werden Sie gesondert darauf Hingewiesen. Sollte noch kein ServicePack in Ihre W2k-Version integriert sein, so können Sie an der Stelle ServicePack auf "Suchen" und "ServicePack integrieren" klicken.

© 2005 - by DT2v.de - all rights reserved


Unattended

  • Hier müssen Sie die Fett markierten Felder vervollständigen. Der Restangaben sind zwar Optional, ein komplettes Ausfüllen erspart Ihnen jedoch u.U. nötige Nacharbeiten.

Optionsbeschreibung

Windows-Ordner: In dieses Verzeichnis wird später Ihre Installation erzeugt. Hinweis: Sollte ohne wichtigen Grund - nicht geändert werden!

Benutzer-Ordner: An dieser Stelle könnten Sie z.B. den Ort für ein Servergespeichertes HOME eingeben. Ansonsten benutzen Sie Standard

Name/Firma: Hier die Daten des Lizenzinhabers

Administrator Passwort: Benennen Sie Hier das Admin-Passwort für Ihre Clients. Dieses wird unverschlüsselt in Winnt.sif eingetragen. Hinweis: Die Angabe Kein widerspricht ggf. den Domänenrichtlinien und sorg ggf. für einen Abbruch der Installation!

Product Key: Tragen Sie an dieser Stelle bitte Ihren Lizenzschlüssel ein (Rückseite der CD-Hülle oder Lizenzunterlagen)

Hier können Sie den Monitor konfigurieren: Selbsterklärend. Beachten Sie bitte die Angaben des Herstellers der Grafikkarte. Die im Bild eingetragenen Werte sind Standardwerte und werden i.d.R. von allen Hersteller unterstützt. Hinweis: Bildwiederholungsrate - das menschliche Auge kann über 75 Hz, keinen Unterschied mehr verfolgen/erkennen.

Folgende Windowskomponenten können Sie Optional installieren lassen
An dieser Stelle haben Sie wiederum die Möglichkeit, für alle beteiligten Rechner die selben Einstellungen zu setzen. Das kleine Zusatzfenster erscheint bei Klick mit der rechten Maustaste, auf die entsprechende Option. Die Option Standard bewirkt eine Installation je nach Windows-Version.


User

An der Stelle muss nichts Erklärt werden. Nur einige Hinweise:

  • Die Passwörter werden in eine Textdatei (settings.txt) - und daher unverschlüsselt - gespeichert

  • Durch Klick auf Hinzufügen können Sie bereits an dieser Stelle, den neuen User in "seine" Bestimmte Gruppe einfügen. Wollen Sie dies nicht, lassen Sie diese Option einfach offen. User, die nicht mit dieser Option "verarbeitet" werden, sind Automatisch der "localgroup" / "Benutzer" hinzugefügt.

    Hinweis: In der XP-Version "Home" finden Sie u.U. diese Kontengruppen nicht.

  • Sollten Sie mehr als nur einen User auf Ihrem System planen, so können Sie an dieser Stelle auch das AutoLogin deaktivieren

  • Ebenso leicht kann der User auch wieder Entfernt werden (z.B. Tippfehler)


Treiber

Diese Option erfordert zu Anfang Ihre volle Konzentration.

Es können keine Treiber in Form von EXE, ZIP, CAB o.ä. integriert werden. Alle Treiber müssen in "ausgepackter" Form auf der Festplatte oder CD vorliegen und Inf-Dateien beinhalten. ZIP-, RAR-, CAB- und andere Archive sowie die meisten EXE-Treiber lassen sich mit Hilfe von WinZIP, WinRAR o.ä. Programmen entpacken.

  • Zuerst vergeben Sie einen Namen für den Treiber - ohne Leerzeichen.
    Zum Beispiel: HP-Drucker, ADAPTEC-RAID, LAN-PRINT ... o.ä.

  • Mit einem Klick auf Hinzufügen erscheint ein weiteres Fenster, in dem Sie den Ordner mit den Installations-Dateien des Treiber auswählen.

  • Auf OK klicken. Daraufhin findet eine Prüfung statt, ob es sich die Inf-Dateien in ausgewähltem Ordner befinden. Anschließend wird der Ordner, unter dem Namen dem Sie dem Treiber vorher gegeben haben - mit auf Ihre CD kopiert.

  • Während der Windows-Installation werden diese Ordner vom Windows-Geräte-Manager durchgesucht und die passenden Treiber installiert.

Tipp: EXE-Treiber, die Sie nicht auspacken konnten, können auch als Software installiert werden.


Hotfixes

Die Integration von Hotfixes wird an der kleinen Beispieldatei Hotfixes-Test.exe erklärt.

  • Als Erstes auf Suchen Klicken und die bereitliegende Datei auswählen.

  • Sollte der Dateiname des Hotfixes mehr als 8 Zeichen aufweisen, werden Sie darauf Hingewiesen. Bitte kürzen Sie den Namen auf 8 Zeichen (8.3 Format) vor dem Punkt.

  • Anschließend sollen Sie die Schalter für unbeaufsichtigte Installation und Unterdrückung des Neustarten einsetzen. In diesem Fall sind es /norestart und /passive. Man kann hierbei rel. leicht Erkennen welcher Schalter, was bewirkt.

  • Zuletzt drücken Sie auf Hinzufügen. Dadurch wird der Hotfix unter neuem Namen auf die zukünftige CD mitkopiert. So verfahren Sie mit jedem Update die Sie an dieser Stelle installieren möchten.

Hinweis: Sollten jedwelche Updates Schwierigkeiten bereiten, so kann diese auch wiederum in 2. Instanz als Software installiert werden.


Software

An dieser Stelle das Beispiel WinZIP - wie man Programme integriert

  • Softwarebezeichnung - Hier tragen Sie den Namen der Software ein. Dieser Name wird später während der Installation angezeigt.

  • Danach auf Hinzufügen drücken. Es kommt ein erneuter Dialog zum Vorschein, in dem Sie die Dateie(n) auswählen können, die zur Installation notwendig sind. Nach Bestätigen durch Öffnen werden die ausgewählte Dateien ins Ordner Software kopiert.

  • Damit das Programm auch installiert wird, muss noch festgelegt werden, Wie es passieren soll. Und das soll in zwei Schritten geschähen. Zuerst soll der Inhalt der WinZIP.REG ins System-Register eintragen und anschließend WinZIP.EXE starten.

Dafür Klicken Sie wiederum auf Suchen und wählen WinZIP.REG aus. Nach Bestätigen durch Öffnen erscheint die Zeile mit %CDROM%\Software\WinZIP.REG. Dieser Zeile fügen Sie folgendes hinzu: regedit /s. Anschliessend Klicken Sie ich auf Hinzufügen.

Damit ist der Erste Teil geschafft

  • RegEdit kopiert Information aus WinZIP.REG ins Sytem-Register. Der Schalter /s läst alles unbeaufsichtigt geschehen.

  • Jetzt ist noch WinZIP.EXE übrig geblieben. Also noch einmal auf Suchen klicken, WinZIP.EXE auswählen und mit Öffnen bestätigen. Sie können dies nun mit dem bereits bekannten Schaltern /silent und /noreboot erweitern, damit die Installation von WinZIP unbeaufsichtigt abläuft und KEIN Restart von Computer stattfindet. Abschließend bestätigen Sie durch Klick auf Hinzufügen. Die Integration von WinZIP ist jetzt komplett.

Ein wichtiger HINWEIS: wenn Sie keinen Schalter von den Programm kennen die Sie integrieren wollen, lassen Sie keine Selbstversuche zu. Sie werden bei den meisten Programmen, während der Installation, aufgefordert z. B. Lizenzbedingungen zu akzeptieren o.ä.. Werden Sie von Programmen aufgefordert den PC neu zu starten, Klicken Sie auf NEIN. Wird der PC neu gestartet, werden alle nachfolgenden Programme nicht installiert!
Nach der Installation des letzten Programms wird Ihr PC i.d.R. automatisch neu gestartet. Sollte dies nicht der Fall sein, erledigen Sie dies am Ende der Installation unbedingt selbst, auch um alle Temporären Ablagen und Speichermodule zu entleeren.

Auf http://unattended.blue-tree.de werden versch. Schalter, für die meistbenutzten Programme, angeboten. Auch ein Besuch im Forum auf der selber Seite kann durchaus recht Hilfreich sein.


Fertigstellen

  • Hierzu muss man nicht mehr viel Ausführen. Einfach auf "Fertigstellen" drücken. (ab Version 0.8.7 wird es zu "Speichern" umbenannt).

  • Dadurch werden die im Bild aufgelisteten Dateien zum Teil überschrieben und zum Teil sogar gelöscht.

  • Anschließend drücken Sie auf ISO-Image erstellen. Es wird eine bootfähige Image erstellt, die Sie auf eine CD oder DVD brennen können.

  • Geben Sie Ihren Speicherplatz für die ISO-Datei an ...

  • Im weiteren Verlauf ...

  • Fertig!

Tipp: Nachdem Sie auf Fertigstellen geklickt haben, können Sie noch immer weitere Änderungen an CD manuell vornehmen z. B. einige System-Dateien patchen o.ä. Drücken Sie anschließend auf "ISO-Image erstellen" und alle Ihre Änderungen werden in ihr_image.iso integriert. Dieses wird auch Nachträglich nochmals überschrieben.


Copyright - Mustererstellung

Design, Herstellung und Realisierung

DATENTECHNIK-Winkler
Inh. Jo. Winkler
iT-Consult, Netzwerktechnik, Systemadministration,
Schul-, Behörden- und Praxis-Netzwerke, Ausrüster für "Ich-AGs"

www.DT2v.de [image] www.TS3D.de

Alle Rechte vorbehalten, weitere Verarbeitung, auch Auszugsweise nur mit vorh. schriftl. Genehmigung des Erstellers


Weiter

Bitte entsprechendes Untermenü verwenden ...